WorldWide Telescope 5.5 for Windows

WorldWide Telescope 5.5 is the latest version of WorldWide Telescope (WWT). This feature-rich application is now available to everyone as a free download.

Download WWT 5.5

WWT 5.5 runs on Windows 7/8/8.1/10, in either 32- or 64-bit mode, depending on your operating system. It also supports native DirectX 11, DirectX 10, and has some support for down-level DirectX 9 hardware running through the DirectX 11 API.

Minimum System Requirements

  • Windows 7/8/8.1/10 (older versions of Windows are not supported)
  • Intel 5th generation (Broadwell) or 6th generation (Skylake) Core i CPU
  • 4 GB system memory
  • Intel Integrated graphics associated with 5th generation (Broadwell) or 6th generation (Skylake) chipsets

Recommended System Requirements

  • Intel 5th generation (Broadwell) or 6th generation (Skylake) Core i7 CPU
  • 8+ GB system memory
  • Discrete graphics card with 1+ GB VRAM, DirectX 10 or DirectX 11 compatibility, such as NVIDIA GTX 480 or ATI Radeon HD 5850 or better.

Do not attempt to install WWT 5.0 or higher on Windows XP. It will not run and can potentially prevent the legacy version from running.


WWT Legacy

The WorldWide Telescope legacy version (WWT 3.1) supports Windows XP, Windows Vista, and DirectX 9.0c hardware running as a 32-bit application. Do not attempt to install WWT 5.0+ on Windows XP. It will not run and can potentially prevent the legacy version from running.

Install the legacy version.

Legacy Windows Modal